MP3 ivo-sound m650 actualize firmware y no enciende.

Seguir
Hola.
hace dos dias compre un mp3 ivo-sound m650 de inmediato lo conecte a mi pc e instale los programas en mi pc que tenia integrados en el.
Por curiosidad use un programa llamado Firmware upgrade, cuando lo use obviamente no sabia para que servia ese programa, en fin la actualizacion se realizo correctamente y aparecio un ventana que decia: "Actualizacion completa, ahora desconecte el reproductor". Despues que lo desconeste de mi pc ya no encendio.
Lo conecto a mi pc y si lo reconoce pero ahora el mp3 cuando esta conectado no enciende la pantalla ni avisa q esta conectado a la pc, lo desconecto y lo intento encender pero no hace nada.
He buscado ayuda en internet pero no he encontrado nada util. Por favor ¿me pueden ayudar?
¿Quiero saber si hay alguna solucion a este problema?
Les dejo adjuntos los manuales para que los revisen ok.
Gracias.


1 Solución propuesta

SOLUCIÓN ACEPTADA
No sé si ya hayas resuelto tu problema, por eso te lo pondré resmuido:
primero baja estos archivos si es que no los tienes http://www.bayconsumer.com/Download/m650/m650_Program_20090709.zip
se encuentran en la página del proveedor http://www.bayconsumer.com/BCI/m650.html
ahora descomprime y ve a esta carpeta \m650_Program_20090709.zip\m650_Program_20090709\Firmware upgrade program ahi debe venir este archivo: m650 Firmware 090708.cab, ese archivo úsalo para actualizar tu firmware (haz lo mismo que hiciste con el archivo que hizo que se te descompusiera, usando el en mp3 utility tool solo seleccionas ese para actualizar y ya)
Espero te haya servido, o a alguna otra persona.