Foros | Webinarios | Blogs
 

Remplazar relay 5v por transistor

Seguir
Hola que tal amigos del foro

Desde hace unos días he estado detrás de un Relay de 5v para un circuito que estoy diseñando el Relay en cuestión es este 
claro lo he estado buscado sin tanta sofisticacion pero en electrónicas locales y entre mis desechos electrónicos no consigo nada solo de 12v 24v y 32v

Así que investigando vi que hay SSR (Solid State Relay) que constan de 2 transistores o almenos a paracer es así 


Aquí la duda que transistores puedo usar en este circuito 

El voltage que tengo es de 3.7v a 5v  y nesisto que los transistores corten o conecten una corriente de 115v para una lámpara fluorescente auto balastrada

El circuito original mente activaba una lámpara Led de 15 leds con 4.5v por grupo de leds 5 leds en cada grupo claro 


Pero ahora nesisto que esa corriente de 5v active los transistores para que encienda la lámpara 

Si alguien tiene una idea de que puedo hacer para fabricar algo así se los agradecería anexo imagen del circuito 
 como verán en L+ y L- iban los leds y ahora hay va el Relay o transistores 

​​​​​​En B+ y B- va la alineación del circuito que será de una fuente de 5v 2a

Y en K K va un switch de activación que suplanta al control remoto 

Espero y alguien me pueda dar una mano 

Por cierto estoy consiente de que el relay no cuesta mas de $100mxn pero en tiendas físicas no lo consigo y pedirlo linia el envío me mata 

Salu2 y gracias de antemano

encontré este diagrama con un optocoplador o como se escriba y un triac me servirá hacer algo similar?


ACTUALIZÓ 

después de analizar el diagrama que encontré y sumarlo al diagrama proporcionado por el compañero Ennio Montenegro M.
Fabrique mi circuito aun no lo pruebo pero dejo foto de el y el diagrama del circuito en total para ya sea de ayuda a otros o me Corrigan si algo esta mal 



  • hace 2 meses

    Avatar de Ennio Montenegro M.

    Es justamente el esquema que estaba buscando y lo puse en mi respuesta.

1 Solución propuesta

SOLUCIÓN ACEPTADA
Jose
Los transistores no comandan corriente alterna. Para comandar corriente alterna, se utilizan los TRIAC.
En el esquema adjunto, La tensión de 5VDC sería la activación de un OPTOTRIAC y la lasida de éste, activará al TRIAC, el que a su vez comandará la luz.

  • hace 2 meses

    Avatar de jose enriquetecnico

    Ok me parace perfecto y no me son componentes ajenos tengo uno triac de un ventilador a control remoto supongo que servirán para el circuito en cuanto al moc3021 supongo que puedo conseguirlo de una fuente de poder conmutada cierto?

  • hace 2 meses

    Avatar de Ennio Montenegro M.

    No lo encuentras en una fuente conmutada, porque utilizan transistores de alta velocidad y no usa TRIAC.

  • hace 2 meses

    Avatar de jose enriquetecnico

    Hola encontré el moc3021 en una fuente de poder de una traga monedas y precisa mente activa un triac bt136 600d el cual hacía que la máquina echará monedas así es que perfecto sacaré el circuito tal cual pero el vez la señal que recibía para echar monedas será la señal del circuito del control remoto y vez del motor será la lámpara empezaré a soldar los componentes y comento que paso

  • hace 2 meses

    Avatar de Ennio Montenegro M.

    Si están buenos los componentes, tiene que funcionar.
    Recuerda que la señal de control del MOC3021 tiene polaridad. Pin 1 + y pin 2 -. Si inviertes la polaridad, no funciona, por éso en tu circuito usa un diodo polarizado inverso en la entrada.

  • hace 2 meses

    Avatar de jose enriquetecnico

    hola compañero ya construí el circuito y anexe el diagrama de el a la pregunta porfa revisa lo y corrígeme si algo esta mal

    salu2

  • hace 2 meses

    Avatar de Ennio Montenegro M.

    Puedes probarlo como está.
    En los dimmers se comanda entre G y M1.

  • hace 2 meses

    Avatar de jose enriquetecnico

    K tal oye lo conecte y siempre queda encendido no importa de apago el circuito o lo desconecto simple mente no se apaga en que me abre equivocado voy a probar con otro triac talvez este en corto

  • hace 2 meses

    Avatar de Ennio Montenegro M.

    Revisa sí está en corto entre M1 y M2.
    Lo otro es desconectar el G

  • hace 2 meses

    Avatar de jose enriquetecnico

    Sip hay corto entre m1 y m2 y desconecte G y aun asi encendió

    Otra cosa el optocupler al estar activado en las patas 6 y 4 debería aver continuidad o voltage no?

  • hace 2 meses

    Avatar de jose enriquetecnico

    Era el triac en corto lo reemplaze y encendió todo ahora lo voy a pasar a una protoboard y después lo instalaré donde va a quedar muchas gracias por su ayuda

  • hace 2 meses

    Avatar de Ennio Montenegro M.

    El opto odría medir algo de resistencia al estar activado, pero con tensión si conduce. No puede haber tensión porque la toma desde la red a través de la lámpara y el triac.

  • hace 2 meses

    Avatar de jose enriquetecnico

    Sip ya que monte todo funciono correcta mente de verdad muchas gracias fue un proyecto muy entretenido y me será de mucha utilidad ya solde todo a una placa y le puse un dispersor al triac

    Espero y a alguien mas le sirva este pequeño proyecto