Tienda | Foros | Blogs | EN
 

Problema de dependencias

Seguir
Hola gente! Hace dos días atrás instalé Ubuntu 8.1. Anda excelente, pero mi problema es con el módem. Tengo el Huawei SmartAX MT810 (el redondito xD). En varios lados vi que explicaban la forma de instalarlo y entre otras cosas me decían que tenía que instalar el paquete build-essential. Lo descargué de http://packages.ubuntu.com/ y quise instalarlo, pero mi problema es el siguiente: me dice que falta g++-4.3. Lo descargué y al querer instalarlo me dice que falta libstdc++6-4.3-dev. También lo descargué pero al querer instalarlo, me dice que depende de g++-4.3

Qué hago???
g++-4.3 depende de libstdc++6-4.3-dev

libstdc++6-4.3-dev depende de g++-4.3

O sea... no puedo instalar ninguno de los dos porque cada uno depende del otro???????
Por cierto: en otros foros me contestaron que haga apt-get etc. etc., pero les recuerdo que lo que quiero instalar es el módem, así que no tengo internet.
A quien pueda ayudarme, muchas gracias desde ya!


5 Soluciones propuestas

http://www.guia-ubuntu.org/index.php?title=Configuraci%C3%B3n_del_modem_Huawei_SmartAX_MT_810


Ahí tenés un tutorial paso a paso y bastante fácil de seguir.
Gracias por el link, pero mi problema como describí más arriba, surge de no poder instalar el build-essential.
La página que me pasaste empieza con:
"Instalación del driver
Antes que nada, debemos instalar los paquetes build-essential, linux-headers-`uname -r` (`uname -r` se reemplaza automáticamente por la versión de nuestro kernel) y libatm1. "
Y después pasa a explicar cómo instalar el ueagle-atm, etc. etc.
Pero cómo instalo el build-essential???????
Mi problema es que me pide uno y otro paquete hasta que al final me pide esos dos, cada uno dependiente del otro.
Mi pregunta es: ¿Cómo instalo esos paquetes?
Gracias!
Primero que nada, activa los repositorios Universe y Multiverse:

Sistema / Administración / Orígenes del software
te pide la contraseña, la señalas Universe y Multiverse
aceptas y listo activados los repositorios.

Luego abres una terminal en:
Aplicaciones / Accesorios / terminal

y tipeas:

sudo aptitude install build-essential

Y listo. Eso con respecto a lo que pediste. Respecto al modem, si es un router no tenes que hacer nada, si es modem USB, para configurar la cuenta tenes que tipear en consola:

sudo pppoeconf

Eso es para configurar tu cuenta, luego para conectarte tenes que tipear:

pon dsl-provider

Y seguir las instrucciones. Cualquier duda consulta!!

Saludos!.
Gracias! finalmente pude resolver mi problema. Según pude interpretar, lo que tenía era un problema de "dependencias cruzadas". Lo solucioné haciendo

$ sudo dpkg -i g++-4.3.deb libstdc++6-4.3-dev

De esta forma pude instalar los dos paquetes que tenían dependencias cruzadas y continuar con la instalación de mi módem.
Por cierto, me ayudó muchísimo la página que me pasaste, noxa.

Gracias a todos por ayudarme!
Para que en otra oportunidad no tengas estos problemas, el build-essential se encuentra en los discos de instalación de Ubunutu , para descargarlo edita tu sources.list , quita la # de la linea que hace mención al cdrom , luego sudo apt-get update y por último usa por ejemplo Synaptic par instalarlo, teniendo por supuesto colocado el cdrom.