Muy buenas, saludos cordiales ante que todo.

Mi portatil, la abri para realizarle limpieza interna y al armar bueno ahora NO me quiere funcionar el muose pack que trae ella misma, la volvi a destapar y verifique el fleje del mismo y resolde los puntos por si no habia buen contacto y los medi con el tester y dan continuidad todos. Y la vólvi a armar.

Ahora al armarla, la pantalla queda en negro y suena 2 pitos primero y depués 3 pitos mas y queda la pantalla en negro.

OJO cuando la arme y no funcionada el mouse pack le coloque uno externo y todo OK hasta escuche musica y demas, Tambien medi la bateria redonda y tiene 2,99 Vdc para mi esta buena y por ultimo voy a aprovechar a verificar ya que la voy a volver a destapar el por que NO me esta cargando la pila, ya que la misma cuando la conecto apagada NO enciende el led de carga de la pila y ahora siempre tengo que tenerla enchufada, esto pasó después de un tiempo aproximadamente como 6 meses que no la use y cuando la conecte para cargarla y verificarla se quedo así que a juro tenía que tenerla con el cargado colocada, no le di importancia sino hasta ahora que decidi limpiarla completamente.

NOTA: En el pin de carga de izquierda a derecha los colores de los cables son  NEGRO, NARANJA NARANJA, NEGRO, ROJO ROJO, y los voltajes respecto a los colores son

Negro - 1er naranja 18.7 Vdc; Negro 2do Naranja 0 Vdc; Negro 1er rojo 19.42 Vdc; Negro 2do Rojo 19.42 Vdc.

Me extraña que en el primer conjunto de cable con el cable negro y 2do naranja NO hay voltaje ?

En los pines de carga de la bateria los voltajes están asi:  tiene 8 pines de izquierda a derecha por lo visto los primero 4 son negativos y los otrs ultimos restantes son los de voltaje, siguiendo este esquema seria:
pin Nro. 1-5 = 3 Vdc; Pin Nro 2-6 = 3 Vdc; Pin Nro 3-7 = 12 Vdc; Pin Nro 4-8 = 12 Vdc,  Estos voltajes son con la berita puesta y el cargador conectado, al sacar el cargador todos los voltajes se van a 0 Vdc y en el pin 3-7 queda un voltaje que empieza a decender.
Esto me indica que al parecer es la pila la que no agarra carga y si es así como se puede hacer para verificar la misma ?

Gracias por su ayuda ante mano