NUEVOS Cursos de Oficios onLine
 

Forula de excel

Seguir
Necesito sacar un porcentaje entre dos valores.
pedido 10 % pedido 11
0 100.00 580
200 21.26 254
1001 #¡div/0! 0
59 -9.26 54
36 0.00 36

pero se daran cuenta que cuando en la columna de pedido11 hay un 0(cero), me da error, como hago para que me de el valor (-100)??
esto es muy urgente por favor al que lo sepa, sera muy agradecido.


    2 Soluciones propuestas

    SOLUCIÓN ACEPTADA
    No entiendo lo que queres hacer, pero el porcentaje lo poodes calcular muy facilmente. Te paso un ejemplo.

    Celda A1, en Formato de Celdas, solapa Numero, configurar cono nunero con 2 decimales (tambien puede ser sin decimales)

    Celda A3, en Formato de Celdas, solapa Numero, configurar cono nunero con 2 decimales (tambien puede ser sin decimales)

    Celda A5, en Formato de Celdas, solapa Numero, configurar cono porcentaje

    Celda A5, escribir la siguiente formula =A1/A3

    Colocar un valor en A3 por ejemplo 10, colocar un valor en A1 por ejemplo 100, en A5 podes ver el porcentaje 10%.

    Por supuesto, cuando en A3 se coloca 0 (cero) en A5 se ve un error porque no se puede dividir por cero.

    Si queres que ese error no aparezca, en A5 hay que hacer un condicional, seria el siguiente =SI(A3<>0,A1/A3,-1)

    LA formula anterior hace lo siguiente: si el valor que hay en A3 es distinto de cero, resuelve el calculo A1/A3, en cambio si el valor que hay en A3 es igual a cero, miltiplica -1 por 100 y lo escribe como porcentaje.

    Saludos Espero te sirva
      Te agrego una opcion mas: en la formula de A5 reemplaza el -1 por 0 (cero).

      Quedaria =SI(A3<>0,A1/A3,0)

      Saludos